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1 Introduction

iBioSim has been developed for the modeling, analysis, and design of genetic circuits. iBioSim
primarily models genetic circuits, but it also supports modeling metabolic networks, cell-signaling
pathways, and other biological and chemical systems. Models in iBioSim use the Systems Biology
Markup Language (SBML). iBioSim also supports importing files using any level or version of
SBML as well as SED-ML files that describe simulation experiments. In addition, it is able to export
projects back to Level 3 Version 1 of SBML. iBioSim is able to support almost all of the core SBML
modeling constructs including hierachical model composition, layout, flux balance constraints, and
arrays packages. However, iBioSim does not support some types of fast reactions. iBioSim was
the first tool to ever produce correct results for all examples in the SBML benchmark suite, and
has also been tested successfully on the stochastic benchmark suite and the curated models in the
BioModels database. iBioSim is also one of the first tools to also support the Synthetic Biology
Open Language (SBOL), an emerging standard for information exchange in synthetic biology.

All files in iBioSim are collected within projects. A project is a collection of models, analysis
views, learn views, and graphs. iBioSim displays all project files on the left margin and the open
models, views, and graphs to the right of the project files. A log of all external commands is
displayed on the bottom. The menu bar is located on the top of the window in the Windows and
Linux versions. In the Mac OS version, the menu bar is located at the top of the screen. The
editors and views included in iBioSim are as follows:

• Part Editor - used to create genetic circuit parts

• Model Editor - used to create models of a genetic circuits or other biological systems

• Analysis Tool - analyzes by abstraction-based ODE, Monte Carlo, or Markov

• SBOL Browser - used to view SBOL files and to associate DNA components to model elements

• Learn Tool - a tool to learn a model from time series data (TSD)

• TSD Graph Editor- visualizes TSD files

• Histogram Graph Editor - visualizes probability data
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The following tutorial will show how to use the first three of the above features included in
iBioSim in addition to the TSD Graph Editor using a model of the Genetic Toggle Switch (Gardner
et al., 2000). For those unfamiliar with the Genetic Toggle Switch, it is the transformation of
bacteria to behave in a certain mode after the introduction of a trigger to the system. This
experiment is based on the principle of operons in bacteria in which repressor proteins bind to
points on bacterial DNA preventing transcription of certain genes. An inducer molecule can bind
to the repressor protein causes it to detach from the DNA allowing for the transcription of the
genes it was previously repressing. The Genetic Toggle Switch utilizes two repressor proteins, LacI
and TetR, that each bind to spots on the DNA that repress the synthesis of the other repressor
protein. For example, LacI is a repressor protein that prevents transcription of the TetR gene. In
this experiment, LacI represses the genes that code for TetR and GFP (Green Fluorescent Protein)
and TetR represses the gene that codes for LacI. When the system is on, the cell glows green, and
when the system is off, the cell does not glow. IPTG is the inducer molecule that turns the switch
on, and aTc is the inducer molecule that turns the switch off. This is just a brief description of the
Genetic Toggle Switch, and more details will be provided in the tutorial.

2 Project Management

• To begin, first open iBioSim. In Mac versions, the executable is located in iBioSim/bin/iBioSim.mac.64.
In Linux versions, the executable is located in iBioSim/bin/iBioSim.linux.64. The windows
version can be opened by accessing iBioSim.jar located in iBioSim/bin/iBioSim.jar. It is
possible to open the jar file in all operating systems, however, the Mac OS menu bars will
not render correctly unless the mac.64 file is opened instead. If the file does not open, refer
to the installation guide.
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• The first step in creating the model of the Genetic Toggle Switch is creating a new project.
Projects in iBioSim are collections of models, simulations, and genetic circuit designs. This
model requires all of these elements, so to create a new project, select the File menu, hover
over New, and select Project. You can also use the keyboard shortcut control → P on the
Windows and Linux versions or command → P on the Mac OS version.
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• You will then be prompted to enter a Project ID.

• Enter SynBioTutorial because this is Synthetic Biology Tutorial for iBioSim in order to create
the project.
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3 Part Editor

3.1 LacI Inverter Gene

• Before we can create our model for the Genetic Toggle Switch, we must first create the genetic
circuits in the model. As aforementioned, there are two, the LacI repressible genes for TetR
and GFP and the TetR repressible gene for LacI. These can be created using the Part Editor
tool in this program, so select the File menu, hover over New, and select Part.
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• You will then be prompted to enter a Part ID for this circuit. This tutorial will start with
the circuit for the LacI repressible genes for TetR and GFP, so enter LacI Inverter Gene into
the Part ID.

• This will then open up the Part Editor allowing us to begin to create the genetic circuit. The
first part of this circuit like many circuits is a promoter, which is where transcription of genes
begin, so click the promoter icon to add it to the circuit. The promotor icon is the second
icon from the left on the part ribbon.
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• The next part of this circuit is the TetR gene, so select the gene icon to add the TetR gene
to the circuit. This will then open the Gene Editor. The gene icon is the first icon from the
left on the part ribbon.
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• Since this is the TetR gene, enter TetR Gene into the Display ID and click Ok to add the
gene to the circuit.
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• Now, do the exact same thing as above to add the GFP gene to the circuit.

• The next step is to add the terminator to the circuit, which is where transcription ends, so
click the terminator icon to add it to the circuit. The terminator icon is the fifth icon from
the left on the part ribbon.
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• Now that the framework for this genetic circuit is laid out, it is now time to begin adding
some of the details. The first step of which is to expand the genes, so select the TetR gene
and the focus in icon from the tool ribbon. The focus in icon is the fourth icon from the right.
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• Now we can add the components of the TetR gene itself to the genetic circuit. Like all
coding sequences, the TetR gene has a ribosome binding site where the ribosome binds during
translation, so click the ribosome binding site icon to add it to the genetic circuit. The
ribosome binding site icon is the third icon from the left on the part ribbon.

• The next part in genes after the ribosome binding site is the coding the sequence, the part of
the gene that codes for the TetR protein, so click the coding sequence icon to add it to the
genetic circuit. The coding sequence icon is the fourth icon from the left on the part ribbon.
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• Now that we have the parts of the TetR gene, it is time to associate the parts of the gene with
the actual DNA sequences that code for these parts of the gene. This is possible due to the
SBOL library in Newcastle University, UK. Note, this part of the tutorial requires an internet
connection in order to access the library, so lets start by selecting the ribosome binding site
and clicking the search part registry icon. The search part registry icon is the third icon from
the left on the tool ribbon.
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• Clicking the search part registry icon opens the Part Registry. First, check that the selected
registry is the SBOL Stack before going on, the SBOL Stack registry being the SBOL library
in Newcastle.
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• The next step is to associate the ribosome binding site with its gene sequence, so in the Filter
Parts criterion, type J61120. The filter is case sensitive so be sure to use a capital ”J”. The
only DNA sequence left after the filter is the DNA sequence for this ribosome binding site,
so select it and click Ok to associate it with this ribosome binding site.
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• Now that the ribosome binding site now has its DNA sequence associated with it, the same
must now be done for the actual coding sequence for the TetR protein, so select the coding
sequence and press the search part registry icon. Currently, the Part Registry takes a little
longer to open for coding sequences than it does for ribosome binding sites, so be patient.
When the Part Registry loads, enter in C0040 in the filter parts criterion, and select the tetR
coding sequence and click Ok to associate it with the coding sequence.
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• Now that the TetR gene is associated with its DNA sequences, the next step is to focus out
back to the genetic circuit as a whole and do the same for the GFP gene, so select the focus
out icon. The focus out icon is the third icon from the right on the tool ribbon.
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• Now select the GFP gene and the focus in icon, and build that gene with a ribosome binding
site and a coding sequence.

• Like before, the next step is to associate the ribosome binding site and the coding sequence
with their respective DNA sequences, so select the ribosome binding site and the search part
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registry icon. In the filter criterion, type J61130, and the select the DNA sequence and
associate it with the ribosome binding site by pressing Ok.

• Next, select the coding sequence and the search part registry icon and type E0040 into the
filter criterion and select the gfp coding sequence. Then, press Ok.
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• Now that the GFP gene is complete, focus back out to the genetic circuit as a whole to
associate the promoter and terminator with their DNA sequences. Next, select the promoter
and the search part registry icon. Then type R0010 in the filter criterion and select the pLac
promoter and press Ok.
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• Now select the terminator and the search part registry icon. This time, type ECK to narrow
the selection to two terminators, and select terminator 2. Then, press Ok.
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• Now that this genetic circuit is complete, in order to successfully integrate it later in the
model, it must be saved before continuing. This can be done by selecting the file menu and
clicking save or by using the shortcut control → S on the Windows and Linux versions or
command → S on the Mac OS version. You will then be prompted that you are saving into
an existing SBOL file. Currently, the part editor works by creating the SBOL when it is
opened, so each time the file is saved, it appears to save onto an existing file, so ignore the
message and select the Overwrite button.
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3.2 TetR Inverter Gene

• As aforementioned, there are two genetic circuits in this model, so now it is time to create the
next one. Select the file menu, hover over New, and select Part. You will then be prompted
to enter a Part ID, so enter TetR Inverter Gene.

• The next steps are more or less the same as the LacI Inverter genetic circuit. The difference
in this circuit is that there is only one gene, so insert a promoter, and then a gene. In the
Gene Editor, under the Display ID criterion, enter LacI because this is the gene that codes
for the LacI repressor protein in the previous genetic circuit.
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• Next, as before, insert the terminator. Then focus in to the LacI gene and insert a ribosome
binding site and coding sequence as before.
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• Now, it is once again time to associate each part of the circuit with its DNA sequence, so
select the ribosome binding site and the search part registry icon. In the filter parts criterion,
type J61101, and select the one that has J61101 in the Display Id and press Ok.
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• Next, select the coding sequence and the search part registry icon. This time in the filter
parts criterion, type C0012 and select the lacI coding sequence and press Ok.

• Next, as before, focus out. Now, it is time to associate the promoter and terminator with
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their DNA sequences, so select the promoter and the search part registry icon. Type R0040
into the filter parts criterion, and select the pTet promoter. Then associate the DNA sequence
by pressing Ok.

• Now, to finish this genetic circuit, select the terminator and the search part registry icon in
order to associate it to its DNA sequence. In the filter parts criterion, type ECK1200 and
select Terminator 1 and press Ok to complete the genetic circuit.

27



• Now, as before, don’t forget to save the genetic circuit. This will cause the warning message
to appear again warning that you are saving into an existing file, ignore the message and
select overwrite.
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4 Model Editor

• Now that we have finished creating the genetic circuits that are part of this genetic toggle
switch model, we can begin building the model. This tutorial will show how to model the
genetic toggle switch using a hierarchical model, building two modules before the final model,
so without further ado, let’s begin with the LacI Inverter.

4.1 LacI Inverter

• In order to begin creating our model, select the File menu, hover over New, and select Model.
You could also use the keyboard shortcut control → M on the Windows and Linux versions
or command → M on the Mac OS version.

• You will then be prompted to enter a Model ID. Enter LacI Inverter into the Model ID because
this particular model will model the repression of the GFP (Green Fluorescent Protein) gene
by the LacI protein.
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• The next step is to add the proteins involved in this operon. In this particular model, there are

three proteins; LacI, TetR, and GFP. So click on the Add Species icon on the tool ribbon
and click on three different locations on the schematic canvas to create the three proteins.
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• Next, select the cursor icon from the tool ribbon and double-click on one of the proteins
to open the Species Editor.
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• In the ID criterion, enter LacI.

• Now, change, the port type to input. This specifies that the LacI protein will be imported
into this model from a different model that will be created later.

• Click Ok to save the entered criteria in the Species Editor.

• Now, double-click on another of the proteins to open its Species Editor.

• Enter TetR into the ID criterion of this protein.
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• This time, change the port type to output specifying that this protein will be exported into
to another model that will be created later in this tutorial.

• Finally, click Ok to save the entered criteria for this protein.

• Now, double-click on the last protein to open its Species Editor.

• Enter GFP into its ID criterion, and once again select output on the port type.

• Now, click Ok to save the entered criteria.
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• The next step is to add a promoter to this model to order to specify which genes are present

in this operon, so click the promoter icon. on the tool ribbon and click on the schematic
canvas to add a promoter to the model.
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• Now, select the cursor icon again from the tool ribbon and double click the promoter to
open the Promoter Editor.

• Enter pLac into the ID criterion because it is the promoter in the Lac operon.

35



• Now click on Associate SBOL near the bottom of the Promoter Editor to open the SBOL
editor in order to associate the LacI Inverter Gene made in Part Editor with this promoter.
This will open the SBOL Association window.

• Click add to open the SBOL Browser in order to find the genetic circuit file created earlier in
this tutorial. Scroll down the Component Definitions until you find the LacI Inverter Gene,
then press Ok to add it to the SBOL Association window.
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• Press Ok on the SBOL Association and on the Promoter Editor window to associate our LacI
Inverter Gene genetic circuit with the pLac promoter.
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• As you may now notice, the promoter tile has been replaced with a new grey tile that resembles
a genetic circuit. This indicates that this promoter is now associated with an SBOL file.
The next step is to show the interactions between the proteins and the promoter. The pLac
promoter is repressible by LacI, so in order to show this relationship, first select the repression

icon .

• In order to show that LacI represses the transcription of the TetR and GFP genes, hover over
the LacI protein highlighting it. Now, while holding down the mouse button, draw a line
connecting the LacI protein to the pLac promoter.
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• To show that the promoter leads to the transcription and translation of the TetR and GFP
genes, hover over the promoter and while holding down the mouse button and draw a line to
the TetR protein and then do the same for the GFP genes.

4.2 TetR Inverter

• The next step is to create the model of TetR repressing the LacI gene, so select the file menu
and hover over New and then select Model. Enter TetR Inverter in the Model ID.
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• Once again, it is necessary to add the proteins involved in this models, namely TetR and LacI,

so select the Add Species icon from the tool ribbon and click on two different locations
on the schematic canvas to create the two proteins.

• Now, select the cursor icon and double-click on one of the proteins to open the Species
Editor. Enter TetR into the ID criterion and select input in the Port Type criterion to specify
that TetR comes from the model that shall be created next and then click Ok.
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• Now, double-click on the remaining protein to open its Species Editor, and enter LacI into the
ID criterion and export into the Port Type criterion. In the Initial Amount/Concentration,
type in 60 because this model starts out with the GFP gene suppressed.

• Next, as before, insert a promoter into the model, so that we can begin to establish the
relationship between LacI and TetR.
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• Then select the cursor icon and double-click the promoter to open the promoter editor.
In the ID criterion, type pTet because this is the TetR repressible promoter that leads to the
translation and transcription of LacI.

• Now click the Associate SBOL button to open the SBOL Association window. This time
however, select the Reverse Complement box because this gene is on the opposite side of the
DNA as the previous two genes in the LacI Inverter model.
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• Once again, click the Add button to open the SBOL Browser. In the Component Definitions,
scroll down to the TetR Inverter Gene made earlier in this tutorial.

• Press Ok on the SBOL Browser menu, the SBOL Association window, and the Promoter
Editor Window to associate the genetic circuit with the promoter.
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• Now, to show that TetR represses the transcription and translation of the LacI gene, select

the repression icon from the tool ribbon and draw a line from the TetR protein to the
promoter. Then, to show pTet leads to the production of LacI, draw line from the pTet
promoter to LacI.

4.3 Genetic Toggle Switch Model

• Now that these two models are completed, we can finally create the Genetic Toggle Switch
model, so first, create a new model called GeneticToggle.
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• Make sure the cursor icon is selected and double-click on the schematic canvas to open
the Compartment Editor.

• Deselect Is Mapped to a Port because this model encompasses the other two models that
were just created (hierarchical model).

• Now click Ok.

• Then, the proteins involved in the Genetic Toggle, GFP, TetR, and LacI must be added to

this model, so select the Add Species icon and click on the schematic canvas three times.

• Select the cursor icon from the tool ribbon and double-click on one of the proteins to
open the Species Editor, and then, enter LacI in the ID criterion. This time, leave the Port
Type on internal because the LacI is not entering this model from somewhere else or going
into another model. In addition, under Conversion Factor Indices, select Degrades to indicate
that this protein degrades overtime. Then press Ok.
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• Now, open the Species Editor for the other two proteins and enter TetR and GFP into their
ID criterions. Under Conversion Factor Indices for both proteins, select degrades. Just like
LacI, both of these proteins degrade over time in biological systems. Click Ok to save these
criteria.

• It is now necessary to add the previous two models to this model, so select the Add Module

icon from the tool ribbon and click on the schematic canvas.

• Now select the LacI Inverter model and click Ok to add it to this model.

• Click on the schematic canvas again and select the TetR Inverter to add it to this model.

• Now, it is necessary to show the relationship between the models and proteins. First select
the arrow icon and draw a line from the LacI protein to the LacI Inverter module to indicate
that the LacI protein in this model is the inputted protein in the LacI Inverter model.

• Now, draw a line from the LacI Inverter Module to the TetR protein.

• Since there are two output ports, you must select the TetR protein port to continue in order
to confirm that output TetR protein corresponds to the internal TetR protein in this model.

• Now draw a line from the TetR protein to the TetR Inverter module to link the internal TetR
protein in this model to the inputted TetR protein in the TetR Inverter model.

• Next, connect the TetR Inverter module to the LacI protein to link the outputted LacI protein
in the TetR Inverter model to this model.

• Finally, draw a line from the LacI Inverter module to the GFP protein to link the outputted
GFP protein in the LacI Inverter model to this model’s internal GFP protein.

• The next step is to add the inducers that flip this genetic toggle switch on and off, IPTG and

aTc respectively, so select the Add Species icon from the tool ribbon and click on two
areas of the schematic canvas.
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• Now select the cursor icon from the tool ribbon and double-click one of the proteins to
open the Species Editor.

• Enter IPTG in the ID criterion.

• Under the Conversion Factor Indices, select Boundary Condition in order to specify that its
concentration remains constant for the purposes of this model.

• Click Ok to save the criteria.

• Now double-click the remaining protein to open its Species Editor.

• Enter aTc in the ID criterion and once again select Boundary Condition under the Conversion
Factor Indices.

• Click Ok to save the entered criteria.

• In operons, an inducer works by binding to the repressor protein changing the shape of the
protein, so it no longer binds to the DNA before the promoter. This can be represented in
this model by forming complexes of IPTG and LacI as well aTc and TetR, so select the Add

Species icon from the tool ribbon and click on two areas of the schematic canvas to create
the complexes.

• Now select the cursor icon from the tool ribbon and double-click on one of the complexes
to open the Species Editor.

• Under the item criterion, type IPTG LacI to indicate that this is the complex formed by
IPTG binding to LacI.

• Under the Conversion Factor Indices, select Degrades because this complex over time in
biological systems eventually degrades.

• Now double-click the remaining complex to open its Species Editor, and label this one’s ID
as aTc TetR to indicate that this complex is formed by aTc binding to TetR.

• Once again, under the Conversion Factor Indices, select Degrades for the same reason as
IPTG LacI complex.

• Now, it is necessary to show the relationship among the complex, the inducer, and repres-

sor protein, so select the Complex Formation Icon and draw a line from IPTG to the
IPTG LacI complex as well as a line from LacI to the IPTG to show that a complex is formed
when IPTG binds to LacI.

• Now, connect aTc to the aTc TetR complex as well as TetR to the aTc TetR complex to
show that aTc and TetR form a complex when aTc binds to TetR.

• The default Stoichiometry of binding for complex formation is 2. However, since these re-
actions only require one of each reactant to form one complex, the Stoichiometry of binding

for these reactions is 1. So, select the cursor icon and double-click one of the lines that
connects a reactant to one of the complexes and under Stoichiometry of binding (nc), change
default to custom and change the parameter from 2 to 1.
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• Repeat the above step for each of the lines connecting the reactants to the two complexes.

• The final step is to add events to change the amount of IPTG and aTc present in the system

to turn the genetic toggle switch on and off, so select the Event Icon and click on the
schematic canvas to add an event and open the Event Editor.

• Under the ID criterion, label the event IPTG High because this event will increase the amount
of IPTG in the system at a specific time.

• Under the Delay criterion, type 2000 to specify the amount of time before the event will be
allowed to trigger, so that the switch starts in the off position for a period of time.

• Now go up to the Trigger condition and type true to specify that the event will trigger
immediately at time equals 2000.

• Next, click on Add Assignment to open the Event Assignment Editor to specify what the
event shall do when it triggers.

• In the Event Assignment Editor, set the variable to IPTG because this event will increase
the amount of IPTG present in the system.

• Next, set the Assignment to 60 in order to increase the IPTG present from 0 to 60 because
enough IPTG must be present in the system to stop the repression of the TetR and GFP
genes by LacI to turn the switch on.

• Now, click on the Add button in the Event Assignment Editor to add this assignment to the
editor.

• Click on the Add button in the Event Editor to create the event.

• The next event that needs to be created is necessary to lower the IPTG value back to zero
in order to show that the switch remains on even when the inducer is no longer present, so
click on another space on the schematic canvas to create another event.

• Under the ID criterion, type IPTG Low because this event will lower the IPTG present in
the system back to 0.

• Under the Delay criterion, set the value to 4000 because this event should occur after some
time after the previous event raises the IPTG value.

• Set the Trigger condition to true, so the event will trigger at time 4000.

• Now, the purpose of the event must be set, so click the Add Assignment to open the Event
Assignment Editor.

• Set the variable to IPTG again because this event will lower the concentration of IPTG, and
set the Assignment criterion to 0 to lower the IPTG in the system back from 60 to 0.

• Click on the Add button to finalize the assignment, and then click on the Add button in the
Event Editor to create the event.

• The next step is to create the events that turn the switch off, so click in another location in
the schematic canvas to open the Event Editor to create another event.
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• Under the ID criterion, type aTc High because this event will increase the amount of aTc
present in the system to turn the switch off.

• Set the Delay criterion for this event to 6000 because it should occur after the previous events,
and once again, set the Trigger criterion to true so the event occurs at 6000.

• Click on Add Assignment so that the event increases the aTc concentration at time equals
6000.

• Set the variable to aTc this time because that is the molecule concentration being changed.

• Under the Assignment criterion, set the value to 60 to raise the aTc concentration from 0 to
60.

• Click Add to add this assignment to the event, and then click Add in the Event Editor to
create the event.

• The last event that needs to be created will essentially reset the system back to its starting
state, so once again, click another place on the schematic canvas to create another event.

• Under the ID criterion in the Event Editor, type aTc Low because this event will lower aTc
back to 0 resetting the system back to the way it was at time equals 0.

• Under the Delay criteria, set the value to 8000, so the event occurs after the previous three
events.

• Now, set the Trigger criterion to true, so the event triggers right at time equals 8000.

• Click Add Assignment to open the Event Assignment Editor in order to specify what the
event does.

• Set the variable to aTc because this event will lower the concentration of aTc, and set the
Assignment criterion to 0 to lower the aTc concentration back to 0.

• Click Add to add the assignment to the Event, and then click Add in the Event Editor to
create the event.

• Now select the File Menu and click Save.

Let us know see how to create a new model using the Model Editor. First, select New →
Model from the File menu as shown below. You will then be prompted to enter a model ID. Enter
LacI Inverter. At this point, a Model editor will open in a new tab.
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To add a chemical species, select the Add Species icon and click on the schematic canvas
(note that this can also be done using the Edit menu or the hotkeys shown in this menu). This will
drop a new species with default ID and other values. You may change these defaults by clicking

on the selection icon , and double-clicking on the species to open the Species Editor. In this
case, let us change the ID to LacI and change the Port type to input. We will leave all the other
values at their default values. The port type of input indicates that this species will be used as an
input for the LacI inverter. Note that while in the select mode, you can also select an object in
the schematic and move it by moving the mouse while holding the left mouse button. Pressing the
right mouse button while an object is selected brings up a menu that allows you to delete an object
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from the schematic. Repeat the steps above to add TetR and GFP species. Give these species port
type of output.

Next, let’s add the pLac promoter, which initiates transcription of the gene that produces the

proteins TetR and GFP. To do this, select the promoter icon and click on the schematic canvas
to drop the promoter with a default ID and parameter values. Double-click on the promoter to
bring up the promoter editor. Change the ID to pLac.
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The pLac promoter is repressed by the LacI species. To create this relationship, select the

repression arc icon , highlight the LacI species, and, while holding the mouse button, stretch
the repression arc to the pLac promoter.

As mentioned earlier, the pLac promoter initiates the production of the TetR and GFP species.
Highlight the pLac promoter and, while holding the mouse button, stretch the production arc to
the TetR species. Repeat these steps to create a production arc between the pLac promoter and
GFP species. Note that any regulation icon can be selected for this because all arcs from promoters
to species are always production arcs.
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Let us now annotate the LacI inverter with its DNA sequence. To do this, we will need to first
import some annotated sequence data stored using the synthetic biology open language (SBOL).
Select the File → Import → SBOL File menu option as shown below. This will bring up a file
browser. You will need to find the location where iBioSim is installed, and the file you want to
import should be located in iBioSim/docs/SynBioTutorial/SBOL/GeneticToggle.sbol.

Next, click on the Model button in the schematic editor which brings up the Model editor shown
below.

54



Next, click on the Associate SBOL button, highlight the placeholder for the DNA component,
and click the Remove button. Then, press the Add button which will open the SBOL browser shown
below. In the list of DNA components, scroll down to the component named pIKERightCassette 1,
select it, and press OK.

The SBOL association editor should now show this DNA component as being associated with
this model. We could now add more components, if we wish, but only one is needed for this, so
press Ok. We are now done with the LacI inverter model, so let’s make sure the model is saved by

either clicking on the Save icon or selecting the Save option from the File menu.
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Next, repeat the steps above to create a TetR Inverter model. The TetR inverter has input
TetR and output LacI. In the TetR inverter, TetR represses the production of LacI. To indicate this,

select the repression icon , highlight the TetR species and stretch the arc to the LacI species.
This action creates an implicit promoter P0 that is repressed by TetR and initiates production of
LacI. When you associate SBOL with this model, select the pIKELeftCassette 1 component, and
select for it to be put on the Minus Strand by checking the box on the SBOL association window.

Do not forget to save this model either by clicking on the Save icon or selecting the Save option
from the File menu.

Now, let us put these genetic inverters into a new model called GeneticToggle. This model will
be the top-level model, and all elements of this model will be enclosed in this model’s compartment.
Compartments are the membrane-enclosed regions where species can be found and reactions take
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place. iBioSim creates a default compartment initially with the ID of Cell. If you click on the
schematic within the Cell compartment, it brings up the compartment editor. Uncheck the “Is
Mapped to a Port”. This indicates that this compartment should be enclosing this model and not
replaced when instantiated in a larger model. Once you press OK, you will notice that the com-
partment now has rounded corners to indicate that this is membrane enclosed by the compartment
Cell.

Now, lets add the LacI Inverter component to this model. Select the Add Component icon
and click on the Schematic canvas opening the Add Component(s) window. In this window, browse
the combo box, if necessary, to find your LacI Inverter model. Pressing OK will then add it to your
schematic. Repeat these steps to add the TetR Inverter.
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The next step is to connect the components through their species. To do this, add species to
the model for LacI, TetR, and GFP. Mark that each of these species degrades, and set the initial
amount of LacI to 60. The degrades checkbox means that when this model is analyzed a default
degradation reaction will be created which has a rate of 0.0075. Next, highlight the LacI species
and stretch a connection to the LacI Inverter connecting it to its LacI input port. Next, highlight
the LacI Inverter and stretch to the TetR species. In this case, since there are two output ports, you
must select the TetR output port is the one desired. Next, highlight the TetR species and stretch
to the TetR Inverter to connect to the TetR input port. Next, highlight the TetR Inverter and
stretch to the LacI species to connect it to its LacI output port. Finally, highlight the Lac Inverter
and stretch to the GFP species being sure to select to connect to its GFP output port.

By instantiating these models together, the SBOL associated with each component will now be
composed as well. To add some description for this composite DNA component, click on the Model
button, followed by the Associate SBOL button on the Model Editor, and finally the Edit Composite
button on the SBOL Association window. You can now add an ID, Name, and Description for this
composite DNA component as shown below.
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Next let us add the complex formation reactions that sequester LacI and TetR preventing them
from acting as repressors. First, add the small molecule species IPTG and aTc. Select boundary
condition to indicate they are replenished inputs to the system. Next, add the complex species

IPTG LacI and aTc TetR and mark that they degrade. Now, select the complex formation icon ,
highlight the IPTG species, and, while holding the mouse button, stretch the complex formation
arc to the IPTG LacI species. Repeat this step to connect complex formation arcs between LacI
and this complex, as well as from aTc and TetR to the aTc TetR complex. Finally, click on the

selection icon , and double-click on each complex formation to open the Influence Editor. In
this editor, change the Stoichiometry of binding (nc) from 2 to 1 by first changing “default” to
“custom” then editing the value.

The final step in the model creation is to add some discrete events to change the amounts of
IPTG and aTc, so we may see the genetic toggle switch change state during simulation. First, select
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the event icon , and click on the schematic to add an event. This action opens the event editor.
In this editor, create an event with ID “IPTG High”, a trigger of “true”, and a delay of 2000.
Next, click on Add Assignment to bring up the Event Assignment Editor. In this editor, select
the variable IPTG and provide the assignment of 60. Press the Add button to add the assignment
and the Add button to add the event. This event will cause the amount of IPTG to change to
60 molecules after 2000 seconds of simulation time. Repeat these steps to create an “IPTG Low”
event with a delay of 4000 which assigns 0 to IPTG, an “aTc High” event with a delay of 6000
which assigns 60 to aTc, and finally an “aTc Low” event with a delay of 8000 which assigns 0 to
aTc.

You should now have a complete model of the genetic toggle switch that looks like the one below
(though locations of elements may be different). Make sure the model is saved by either clicking

on the Save icon or selecting the Save option from the File menu.
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5 SBOL Browser

As mentioned above, a composite DNA component has been constructed for the entire genetic
toggle switch. To see this component, click on the GeneticToggle.sbol file in the list of project
files to open the SBOL browser. On the right side, scroll down and select the DNA component
that you named MyGeneticToggle. You will now see the complete annotated DNA sequence for
this component. Note how the pIKELeftCassette 1 has been put on the minus strand while the
pIKERightCassette 1 follows it on the positive strand.
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6 Analysis Tool

This section describes how to analyze the model just created. The first step is to create an
analysis view. To do this, right-click on the model file and select Create Analysis View. Enter the
analysis ID GeneticToggle or just press enter. At this point, a new analysis view should open.
You should also notice that an icon appears next to your model file. When you click on this, it will
show you all of the analysis and learn views associated with this model.

In order to perform analysis, the analysis tool first converts the model into a detailed reaction-
based model. There are three different ways to see the reaction-based model that is produced. If
GraphViz is installed on your computer, you can select Network for your Simulation Type. Then,

either press the Save and Run icon or select the Save and Run option from the File menu. The
result will be a GraphViz window that will open to show the reaction-based model such as the one
shown below for our example. If it does not open in GraphViz, make sure that you have files with
the .dot file extension associated with GraphViz on your computer. You can also view the model
in a web browser by selecting Browser for your simulation type. In this case, you should ensure
that you have files with the .xhtml extension associated with your favorite browser. Finally, you
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can save the reaction-based model by selecting Model as your simulation type. In this case, you
must provide a new model ID. This new model will appear in your project and it can be opened in
the Model Editor. Since this model does not include any layout information, you will need to either
lay it out by hand or using one of the default layout routines selectable using the Apply Layout

icon .
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As you can see, this model is quite complex. A simple model can be generated by selecting
Abstraction to reduce the model using reaction-based abstractions based on the quasi-steady state
assumption. The abstracted model shown below is reduced from 15 species and 13 reactions to just
5 species and 5 reactions.
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Now, go back to the simulation options tab. Here, make sure that Abstraction is still selected,
change the simulation type back to ODE, the simulator to Runge-Kutta-Fehlberg, the time limit
to 10000.0, the print interval to 100.0, and enter a Simulation ID of ode. Then, either press the

Save and Run icon or select the Save and Run option from the File menu. After the simulation
completes, click on the TSD Graph tab. Double-click on the graph to bring up the graph editor.
Open the ode simulation, highlight Average, select aTc, IPTG, and GFP, change the Title to “ODE
Simulation Results”, change the X-Axis Label to “Time (seconds)”, and change the Y-Axis Label
to “Number of Molecules”. Press the OK button.
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Graphs can be exported in a variety of formats including:

• Time series data format (tsd).

• Comma separated value (csv).

• Column separated data (dat).

• Encapsulated postscript (eps).

• Joint Photographic Experts Group (jpg).

• Portable document format (pdf).
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• Portable network graphics (png).

• Scalable vector graphics (svg).

In order to export a graph, you can either click on the Export icon or select one of the graph
export options from the File menu. When using the Export icon, the type of file exported will
depend on the extension provided to the file name. Click on the Export icon, browse to a location
on your file system, and enter the file name of ode.pdf to create a PDF file for your graph.

Now, select the Simulation Options tab again, select Monte Carlo, change the simulator SSA-
Direct, the number of runs to 100, set the simulation ID to ssa, and click on the Save and Run
icon. Click on the TSD Graph tab. Double-click on the graph to bring up the graph editor. Click
on Deselect All to remove the plotted points. Open the ssa simulation directory, and highlight
run-1. Select aTc, IPTG, and GFP, and change the title to “SSA Simulation Results”. Press the
OK button. Click on the Export icon and enter the file name ssa-1.pdf. Repeat these steps to
generate graphs for the average (average.pdf).
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Another way to view simulation results is on the schematic. To do this, click on the schematic
tab. At the bottom of the window, select the Choose Simulation button, which brings up a window
with all the simulations in this analysis view. Open the ssa directory, select run-1.tsd, and press
OK.
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Now, click on the GFP species, which brings up the Edit Species window. Select the Appearance
tab. Here you can select how you want the species to appear as you playback the simulation. You
can have it change color, size, and/or opacity on a gradient. You can also select the range of molecule
counts to specify the ends of the gradient(s). Finally, you can indicate that these selections are
either for this species or all species in the model. For our example, let’s make GFP follow a green
color gradient, IPTG follow a blue color gradient, LacI follow a cyan color gradient, aTc follow a
red color gradient, and TetR follow a magenta gradient.

Once you have made your selections, you can now play back the simulation. You can either

single-step the simulation by pressing the icon or play continuously by pressing the icon.

The playback can also be paused by pressing the icon and restarted by pressing the icon.
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7 Grid Models

In the last example, we will build a model with a grid. Create a grid model using the File →
New→ Grid Model menu, and name the new model Population. In the create grid window shown
below, select your copy of your GeneticToggle model and change the number of rows and columns
to 5.

The schematic in a grid model is a bit different. It includes a grid in which each location can
be empty or contain exactly one component. Only components can be added to grids.
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Next, right-click on the Population model and create an analysis view. Select Abstraction,
Monte Carlo, and the SSA-Direct simulator. Set the time limit to 10000 with a print interval of
100, change the number of runs to 1, and perform the simulation. Now, go to the schematic tab and
press the Choose Simulation button to select run-1.tsd. Click on one of the genetic toggle switch
models to bring up the Edit Species editor. Select the GFP species and a green color gradient, and
apply to all components with this model. Now, play back the simulation to see the toggle switches
turn on and off.
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